Started about 1 month agoJune 25, 2026Lasted about 2 hoursJune 25, 20261:303:09 PMUTC
Affected
Portal
Degraded performance from 1:30 PM to 3:09 PM
Updates
Resolved
UTC
Resolved
UTC
This incident has been resolved.
Identified
UTC
Identified
UTC
Appointment times are not currently displaying correctly on the Scheduling Confirmation and View Appointment pages. We are continuing to work on a fix for this incident.